Problemas para instalar o WoeUSB no Debian, Ubuntu e derivados [Resolvido]

Autor: Cézar Augusto de Campos
14 de maio de 2020

Ultimamente eu vi algumas pessoas relatando aqui no fórum sobre problemas com a instalação do WoeUSB. Essa dica visa esclarecer o que está acontecendo e como resolver este problema.

O WoeUSB está com problemas de empacotamento, principalmente nas distros Debian. Ele depende de um pacote chamado libwxgtk3.0-dev o qual não está mais disponível no repositório e isso faz com que ele não seja possível de instalar no Debian e Ubuntu, nem mesmo a versão do PPA do Ubuntu está funcionando. Isso acontece porque o pacote mudou de nome, logo o mantenedor do pacote deveria atualizar o sistema de empacotamento para a dependência com o novo nome libwxgtk3.0-gtk3-dev.

Como resolver este problema? Teoricamente qualquer pessoa pode baixar o código-fonte do WoeUSB, atualizar as dependências no arquivo WoeUSB/debian/control e fazer um novo pacote .deb.

Mas como essa dica é voltada a iniciantes, então eu vou passar o link de alguém que já fez isso.

Acesse esse link: WoeUSB doesn't install on Ubuntu 20.04 - Issue #311 - slacka/WoeUSB - GitHub

Clique em woeusb.zip e quando terminar de baixar extraia o arquivo.

Você vai ver um pacote deb chamado: woeusb_3.3.1_amd64.deb

Instale-o via interface gráfica com o Gdeb ou pelo terminal:

# apt install ./woeusb_3.3.1_amd64.deb

O apt deverá resolver as dependências para você e instalar o pacote.

É isso, aproveite o WoeUSB.